【Flutter】在Android Studio安装Android SDK Command-line Tools后Flutter Doctor仍报错

【Flutter】在Android Studio安装Android SDK Command-line Tools后Flutter Doctor仍报错

wpbkj
2022-12-26 / 639 阅读 / 正在检测是否收录...
温馨提示:
本文最后更新于2023年01月23日,已超过445天没有更新,若内容或图片失效,请发送邮件至admin@wpbkj.com。

今天运行Flutter Doctor时发现如下报错

[✗] Android toolchain - develop for Android devices
✗ cmdline-tools component is missing
  Run `path/to/sdkmanager --install "cmdline-tools;latest"`
  See https://developer.android.com/studio/command-line for more details.

可以看到提示SDK的cmdline-tools未安装,按理说去Android Studio的设置中安装即可,但安装后仍报错,原因是我改过一次SDK的路径,将默认路径改到了F盘中。

解决办法:

改变Flutter Config设置

 flutter config --android-sdk "F:\android\sdk"

将Flutter Config中的Android SDK路径改为自己的即可

4
知识共享许可协议
MySSL 安全签章
TrustAsia 安全签章